Goth Dreams V4

 

Gothic Dream comes with a dress, a jacket, lace overlays for the dress and shoes.
A must have for any runtime and any self respecting goth or emo.

Needed Files List and System Required:

Daz 3D V4.2++Morphs
Poser 7, 8
PC or Mac

 

 Gothic Dreams V4
Gothic Dreams Templates


  • Manufactured by: sanbie

This product was added to our catalog on Thursday 14 August, 2014.

Follow fantasiesrealm on Twitter Follow fantasiesrealm on Pinterest

Your IP Address is: 18.212.93.234
2007 until present to Fantasy Attic | Site designed by Angelwing Creations | Powered by Zen Cart