Celtic Cross Earrings for V4 & Dawn

A pair of Celtic Cross earrings for Vicky 4 and Dawn.


System Requirements:

PC and Mac compatible
Poser 4.01 and above or Daz Studio.


Needed Files:

Vicky 4 or Dawn

Poser 4.01+

Daz Studio.


Celtic Cross Earrings

  • Manufactured by: Prae

This product was added to our catalog on Sunday 10 August, 2014.

Follow fantasiesrealm on Twitter Follow fantasiesrealm on Pinterest

Your IP Address is:
2007 until present to Fantasy Attic | Site designed by Angelwing Creations | Powered by Zen Cart