BQ for Amaranth's Get Funky Dress

Needed Files List and System Required:
Get Funky Gen2 by Amaranth
Daz Studio 4.5+
Poser 5+
Daz Studio's Gen2
--------------
Simply unzip the file and install to your poser's runtime folder


BQ for Amaranth Get Funky Outfit[Genesis 2]


  • Manufactured by: MythicalButterfly Design Studios

Follow fantasiesrealm on Twitter Follow fantasiesrealm on Pinterest

Your IP Address is: 54.242.205.33
2007 until present to Fantasy Attic | Site designed by Angelwing Creations | Powered by Zen Cart